send mail

 laravel
  آخرین بروزرسانی : 4 سال پیش توسط آرمان بابایی
لینک کوتاه برای اشتراک گذاری:
علیرضا یعقوبی ( 4 تجربه )
4 سال پیش

 5

موقع ارسال ایمیل این ارور رو میده 

stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed

 

چه کنم ؟

بهترین پاسخ
آرمان بابایی ( 382 تجربه )
4 سال پیش

به این آدرس در پروژه برید:

\vendor\swiftmailer\lib\classes\Swift\Transport\StreamBuffer.php

در خط 259

$options = array();

این کد رو کامنت کنید.

سپس کد زیر رو همونجا اضافه کنید:

//$options = array();
$options['ssl'] = array('verify_peer' => false, 'verify_peer_name' => false, 'allow_self_signed' => true);

 

آرمان بابایی ( 382 تجربه )
4 سال پیش

به این آدرس در پروژه برید:

\vendor\swiftmailer\lib\classes\Swift\Transport\StreamBuffer.php

در خط 259

$options = array();

این کد رو کامنت کنید.

سپس کد زیر رو همونجا اضافه کنید:

//$options = array();
$options['ssl'] = array('verify_peer' => false, 'verify_peer_name' => false, 'allow_self_signed' => true);

 

آرمان بابایی ( 382 تجربه )
4 سال پیش

باید به گوگل برید و Allow less secure apps رو فعال کنید.

اول به این لینک برید:

https://myaccount.google.com/security#connectedapps

بعد این مسیر رو دنبال کنید:

Sign-in & security -> Connected apps & sites -> Allow less secure apps settings

و تیک گزینه Allow less secure apps  رو فعال کنید.

فایل env. رو هم به شکل زیر تغییر بدید:

MAIL_DRIVER=smtp
MAIL_HOST=smtp.gmail.com
MAIL_PORT=587
[email protected]
MAIL_PASSWORD=xxxxxx
MAIL_ENCRYPTION=tls
علیرضا یعقوبی ( 4 تجربه )
4 سال پیش

ممنون اون ارور حل شد

الان این ارور رو میده :(

Failed to authenticate on SMTP server with username "[email protected]" using 2 possible authenticators

علیرضا یعقوبی ( 4 تجربه )
4 سال پیش

اینهایی که گفتید رو انجام دادم اما نشد

آرمان بابایی ( 382 تجربه )
4 سال پیش

پیشنهاد می کنم یک پرسش جدید ایجاد کنید. به همراه کدتون. توضیح کامل بدین.

2022 © Copyright کليه حقوق مادی و معنوی براي چسبون محفوظ است و هرگونه کپی برداری پیگرد قانونی دارد.